Midrange News for the IBM i Community


Posted by: Chris Proctor
Programmer Analyst
Columbia Sports Company
Portland, OR
WDWTITLE *BOTTOM not working with a window subfile
has no ratings.
Published: 13 Apr 2016
Revised: 20 Apr 2016 - 1095 days ago
Last viewed on: 19 Apr 2019 (2375 views) 

Using IBM i? Need to create Excel, CSV, HTML, JSON, PDF, SPOOL reports? Learn more about the fastest and least expensive tool for the job: SQL iQuery.

WDWTITLE *BOTTOM not working with a window subfile Published by: Chris Proctor on 13 Apr 2016 view comments(5)

Good morning. I have an issue where I'm trying to display the function keys for a window subfile using the WDWTITLE *BOTTOM keyword, but it doesn't seem to be working the way it does with a normal window (no subfile). I really like the way this keyword displays the text in the border of the window. Does *BOTTOM not work for a subfile? Perhaps I need to do the additional record format with the function key descriptions and overlay the window? It'd be so much slicker to do it in one format if possible.

If I need to use another format, is there a way for me to make it transparent so that the border color will show thru? Thanks for any suggestions.

Return to midrangenews.com home page.
Sort Ascend | Descend

COMMENTS

(Sign in to Post a Comment)
Posted by: bobcozzi
Site Admin ****
Chicagoland
Comment on: WDWTITLE *BOTTOM not working with a window subfile
Posted: 3 years 6 days 15 hours 9 minutes ago

Often this is caused by the SFL size. The extra line needed for the subfile must be in the window size definition, and then you may also need *NOMSGLIN to remove that status message area, unless you're usuing it. But that's usually the issue.

Posted by: chrisp
Premium member *
Portland, OR
Comment on: WDWTITLE *BOTTOM not working with a window subfile
Posted: 3 years 6 days 14 hours 32 minutes ago

I'll give that a try. Thanks, Bob!

Posted by: chrisp
Premium member *
Portland, OR
Comment on: WDWTITLE *BOTTOM not working with a window subfile
Posted: 3 years 6 days 11 hours 23 minutes ago

Hi Bob.  I just found out that it's RUMBA that won't display the WDWTITLE at the bottom. CA displays it just fine! What a pain! Lol. Thanks for the help!

Posted by: bobcozzi
Site Admin ****
Chicagoland
Comment on: WDWTITLE *BOTTOM not working with a window subfile
Posted: 3 years 5 days 16 hours 57 minutes ago

People stil use RUMBA? Wow! surprised

Posted by: chrisp
Premium member *
Portland, OR
Comment on: WDWTITLE *BOTTOM not working with a window subfile
Posted: 2 years 11 months 30 days 17 hours 6 minutes ago

Lol!!! Yep! Hard to believe, I know, but Columbia Sportswear is slow to upgrade! Lol